Umbraco Support Unavailable

Incident Report for Umbraco Statuspage

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 08:53 CEST

Monitoring

Intercom is back up and running, though the service may still be slightly slower than usual.
Posted Oct 20, 2025 - 14:12 CEST

Identified

The Umbraco Support service is currently experiencing issues with our service provider, InterCom.
They have an on-going incident. More details here:
https://www.intercomstatus.com/us-hosting
Posted Oct 20, 2025 - 09:51 CEST
This incident affected: Supporting Services.